Shelk-test-1.5.2 
Language
Sections
Search
Electronic stores
Counter
Text guide
 

    User Manual: "Shelk-test" 1.5.2(10/29/2012)

    Copyright © 2009 - 2013 Lab Free Technologies(IE Flegontov D.M.)


    The program for creating tests. Designed for the professional compile a tests and test knowledge of the network.

    Many programs are created for testing as a trio: Module create of the tests, test module and server module, which will be primarily responsible for the test results (journal). Such a method is not considered as effective and, therefore, Shelk-test uses the maximum simplification, in collecting, processing and transmitting data to the log. The program is made by one module, which is especially effective manifests itself when you run it from your server. It uses to store information database (SQLite3), so there is no need to run a server module. Since the test results are stored in the database, then, at the request of the teacher, can be downloaded from any computer, using the same one module. That is, the program may not even be installed on users' computers. The problem of allocation of access rights to create a test solved by using a password to edit mode. It is possible to reserve depository tests with compression. Test file format xwt encrypted and compressed.

    Shelk-test is created using the rules of ergonomics, providing a good user interface and full freedom to work with the program. This freedom is the use of any operating system installed on both the computer clients (students), and the computer server (storage tests). All this became possible due to the fact that the program is cross-platform, uses a database SQLite3 and registers in the registry that allows it to quickly port and deploy to any number of computers. At a separate order - will be ported to your platform.The options are: AIX, AIX-64, BlackBerry armv7le, BlackBerry x86, HP-UX, HP-UX-64, Hurd, iOS, IRIX, IRIX-64, NetBSD, OpenBSD, QNX armv7le, QNX x86, SCO, Symbian, Tru64, UnixWare, WinCE.

    Now assemblies are available for 4-architectures: Intel x86, amd64(EM64T), PowerPC, ARM(!) and 5-platforms: Windows, MacOS, Linux, Solaris, FreeBSD.

    Ability to work in OS MeeGo on Intel Atom and ARM(!) processors.


    Contents

    Test can operate in two modes: "Edititing" and "Testing". In editing mode you can create and editing test. In testing mode can viewing the test and make testing.

    Main window is shown on Image 1.


    Image 1. "Main window".

    All the following activities that occur from the program menu, also duplicated in the toolbar. For the convenience of searching, the names of the buttons correspond to the names of the menu items. It should be noted that for test mainly used button on the Standard toolbar, and for editing the issue, provide a special "Toolbar of editing", "Toolbar of time", "Toolbar of point", "Formatting toolbar". The user, if necessary, can leave one or the other panel on the screen. Select the display panel produced by clicking the right mouse button on the main menu bar or on the free part of an already open bar. By default they are all visible. This is a quick way to change, which will not save settings panel appears when you exit the program.


    Contents


    When you first open the program checks to see if the options file in the system. If he is not found, it shows the welcome screen (Image 2) with short information about the program. Next, you will list where you can select the language of the program(Русский or English).
    Location of the file by default:
    Windows - %APPDATA%;
    Unix - $HOME/.config;
    Embedded Linux - $HOME/Settings;
    Mac OS X - $HOME/.config;


    Image 2. "Welcome".


    Contents


    To work with the program will need to enter your user name and group. In test mode, the data will be used to generate statistics tested. In edit mode, enter only the name of the user. The group default "Teacher." In the future, will be used to maintain the log-file access to the program. Can be useful for administrative purposes. Image 3.


    Image 3. "Enter your user name and group".


    Contents


    To create a test is necessary: in the menu "Test" choose "Create..." - opens a window "Enter the name of the test". In this window are a one-line text field: "Name test", the location chosen in him the values to change the name of the future test.
    After that of choosing the question type. Total of 5 - "One answer," Many answers", "Enter word (sentence) ", "Enter Number","Installation sequence".


    Contents


    Edit text, created the test, comes from the menu "Edit". The following functions: undo, redo, the selection of the text, cut, copy, paste text. Menu "Format" provides opportunities to change the font, text alignment and change its register.


    Contents


    To insert a table, select the menu item "Table" and there is an element of "Insert". The window in which we introduce the number of rows and columns of the table of the future. Item "Add rows..." - Adds the specified number of rows. Element of the "Add columns..." - Adds the specified number of columns in the table. The menu item "Resize..." - Resizes the selected table in the typed.


    Contents


    Adding issue comes from the "Insert->Question->Insert". Total 5 types of questions that can be inserted: "One answer, "Many answers", "Enter a word(sentence)", "Enter number", "Install sequence". Removing the question comes from the menu "Insert->Question->Delete".


    Contents


    Types of questions

    One answer(Image 4). Enter the text in question is the top field for editing. Enter text answer is in the bottom field for editing. After entering the answer, will need to click on the button "Add", the answer is added to the list of answers, located at the bottom of the window. When you add an answer, you can remove it, after selecting it in the list of answers. Changes introduced by the answer is to release a list of answers. After the appearance of text selected answer in the box for editing, and its subsequent changes, you must click on the button to change - response to change in the list of answers. You can also insert / remove the image , which appears in the middle of the window. The correct answer is allocated by clicking in the list of answers. In the process of developing a test, in a window on the left side, will present a list of questions. In the toolbar, you can not customize the main test parameters: time, score, format the text font issue. Splitters (modifiable elements of the window frames) can be customized at your discretion. Everything here has been described and is valid for another type of question, in its description will be omitted.

    Image 4. "One answer".


    Contents


    Many answers(Image 5). Editing as well as "One answer", just a list of responses you can select multiple correct answers.

    Image 5. "Many answers".


    Contents


    Enter word(sentence)(Image 6). The question is introduced into the field for the question at the top of the window. The text of the answer - in the field below to enter the answer.

    Image 6. "Enter word(sentence)".


    Contents


    Enter number(Image 7). The question is entered in the field for the question at the top of the window. Numeric answer is entered into the first counter. In the second and third counters introduced range of values. Include support type real numbers.

    Image 7. "Enter number".


    Contents


    Installation sequence(Image 8). Editing as well as "One answer", only a list of answers to add answers in the correct sequence. In the tests, the answers will automatically be mixed.

    Image 8. "Installation sequence".


    Contents


    Insert an image in question is from the "Insert->Image->Insert". Remove image is from the "Insert->Image->Delete". "Insert->Image->Change" - this element was necessary to change the image that was inserted into the test.


    Contents


    Testing result(Image 9). After testing the user will be written to: Username, the group name, name of the test, all questions, questions asked, skipped questions, correct answers, wrong answers, the quality of knowledge of the material, the total point, count points, time begin, time end, elapsed time and score. Then the data will be saved in 2-and html-file. The first is that can be displayed to the user (student), and the second - a brief detail, which contains the state of the answer to question (correct, incorrect or skipped). They can be opened for viewing in the form of statistics .
    When testing the program can operate one of the two estimation systems: differentiated and undifferentiated. In a differentiated system uses a 5-th Ratings: 1,2,3,4 and 5. The calculation though is according to the table fields, located in the options of the program. Fields are % the quality of knowledge. %, In turn, is calculated based on the number scored of points. Undifferentiated system consists of a 2-ratings: 2 and 5, which by default are replaced by the corresponding words "fail", "Passed". Calculation of ratings is on the same principle as in the differentiated system.

    Image 9. "Testing result".


    Contents


    Statistics(Image 10). Statistics from the menu item called "Service->Statistics". This is the third version of the journal, which lets you work with multiple files of statistics. They are opened by clicking on the button "Open the statistics". It has fields: "Username", "Group name", "Name test", "Total questions", "Questions asked", "Skipped questions", "Right answers", "Wrong answer", "%" absorption material, "Total points", "Count points", "Score", "Date" testing, "Time begin", "Time end" testing, "Elapsed time". Clear the statistics by pressing the button "Clear statistics", located in the lower left. It is possible to print statistics on the printer. During testing, you can monitor the relevance of the data tested, pressing the "Refresh statistics".

    Image 10. "Statistics".


    Contents


    Use Points. The program allows to take into account the points as an additional opportunity to assess the quality of learning material. Set points can be input from the keyboard of values in the field "Panel points", which by default is located in the second row of panels on the left. It contains the following counters: "Current point", "Average point", "Total Points". Current rating for this may vary for each issue. Will automatically be the summation of all points, with entering this value in the counter "Total Points". The value of the average score is reset. Changing meter average score allows you to specify a single value score for all issues simultaneously. There will also be made on the multiplication of the average score on the number of issues - the resulting number will be entered into the computer "Total Points". When you change the total number of points, there will be division entirely, entered value, with the entry of the result in the counter "Current point". Average, thus, will be reset.(Image 2,3,4,5,6)


    Contents


    Time management. The program allows you to limit the time for each subject and for the entire test. If the time for reference work is limited and there is no possibility of each student to persuade him to quickly completing the test, the track of time - an ideal solution. The program itself will count on time and finish the test automatically. The results will be included in the statistics. Set time can be entered from the keyboard a value for the time bar, which by default is located in the second row of panels on the left. It contains the following counters: "Current Time", "Average time", "Total Time". The time may vary for each issue. Automatically will be the summation of all time, with the entry of measured value in the counter of all time. In this case, the value of the average time is reset. Change in the mean time counter allows to specify a time value for all the issues simultaneously. There will also be made multiplying the average time on the number of questions - that number will be entered into the counter of all time. When you change the total value of the time, there will be integer division, the input value, with the entry of the result in the counter is currently. The average time for this to be zeroed out.(Image 2,3,4,5,6)


    Contents


    Opening the test comes from the menu "Test", selecting "Open..." - Open dialog box "List of tests".

    When you select a row with the name of the desired test and follow by pressing "OK", is his discovery.


    Contents


    Test can import from the "Test->Import...". Available import 2-formats: XWT(own portable format) and TXT(plain text format to utf-8). Text format is necessary in order to teacher that you can create a test in a notebook and put it into the program, then save in a depository or in file xwt-format. There are certain rules of writing a text file. "#" Is a control character, that defines the top of the comments. "#sht1.0" - this is the beginning of the file, is located at the first line and defines the current version of the document. The question begins with the numbers in the format "nnn.". The image is preceded by the tag "img:". The correct answer starts with "+" sign. For details, see in the approximate file test.txt in folder tests.

    The program allows you to export the test in the following formats: XWT, PDF, PostScript, HTML, RTF, TXT. Menu "Test->Export->Export test..." open the export dialog box. XWT and Text format(TXT) used to store and transfer tests, followed by the ability to import back to the database repository. While the PDF, PostScript, HTML, necessary for publication on the web pages on the internet and for printing on paper to teachers of all other items not directly related to the work at the computer. RTF-format can still be used for get simple text encoded in utf-8. It uses OpenOffice(or equivalent) with the ability to export to plain text.


    Contents


    Depository is a database SQLite 3. Therefore, adding or deleting tests is adding or removing the corresponding entries in the database. It will be necessary to consider that when you add / delete a record save is done automatically, but if you change entries in the location chosen her name test, keep a record will need to manually click on the button "Save". When you close the changed record (write name) does not make automatically save.

    Depository management test is the menu: "Depository". The items in this menu opens the standard dialog boxes to work with files that allows you to have a database file on the local computer or on a file server. With this organization, storage base, provides simultaneous operation of multiple workstations, both in view and in edit mode.


    Contents


    Navigation between questions going one by one, from the menu "View" - items "Next question", "Previous question" and "Question number...". Still, it can be done using a list of questions to the left of the main window(Image 2).


    Contents


    Changing the language comes from the window options of the program.


    Contents


    1.0.0: Due to the fact that the format the test and database has been changed, it is necessary in older versions (0.4.4, 0.4.7) export all the tests in the xwt file format, In the new version import into the database depository and re-save the tests in the new xwt-format.
    1.5.1: This version supports the 1.0.0 database, so opening it up, make the export of all tests in xwt-files, since they changed the format.


    Contents


    Password in edit mode varies from item "Service->Password mode". Default: "Password"


    Contents


    Saving is selecting the menu item "Test->Save".


    Contents


    Here you can configure: Language, showing the toolbars, choice of the location of the options file of the program and file statistics, the use of which is particularly useful when testing on a local network; time limit for the entire test and for each separate question; automatically run the test. mixing of the questions; limiting the number of questions asked of the total; skiping questions; show results tested; estimation system; remembering the last open database depository of tests; showing the fields of statistics.(Image 11).


    Image 11. Window "Options".


    Contents


    Exit the program is carried out from the menu "Test->Exit".


    Contents


    Main Menu

    Menu "Depository"

    "Depository->Create..." (Ctrl+Shift+N)

    Create of new depository.

    "Depository->Open..." (Ctrl+Alt+O)

    Open new depository.

    "Depository->Restore..."

    Restore depository from the archive.

    "Depository->Close"

    Close of depository.

    "Depository->Backup..." (Ctrl+Shift+B)

    Backup of depository.

    "Depository->Exit" (Ctrl+Q)

    Exit of program.


    Содержание


    Menu "Test"

    "Test->Create..." (Ctrl+N)

    Opens a window where you can enter the name of the new test.

    "Test->Open..." (Ctrl+O)

    Opens a dialog box of the database, which serves to open the test.

    "Test->Import..." (Ctrl+I)

    Opens a dialog to import a test from the file.

    "Test->Run" (Ctrl+R)

    Will launch open test.

    "Test->Stop" (Ctrl+B)

    Stops a running test.

    "Test->Close"

    Close of test.

    "Test->Save" (Ctrl+S)

    Save test into database.

    "Test->Export->Export all tests..."

    Exports all the tests from the database, in files the format chosen.

    "Test->Export->Export a test..." (Ctrl+E)

    Export a test from the database, in file the format chosen.


    Contents


    Menu "Edit"

    "Edit->Undo" (Ctrl+Z)

    Cancels produced action.

    "Edit->Redo" (Ctrl+Shift+Z)

    Repeats undone.

    "Edit->Select All" (Ctrl+A)

    Selects all text.

    "Edit->Cut" (Ctrl+X)

    Cuts the selected text to the clipboard.

    "Edit->Copy" (Ctrl+C)

    Copies the selected text to the clipboard.

    "Edit->Paste" (Ctrl+V)

    Pastes text from the clipboard.


    Contents


    Menu "View"

    "View->Image->Zoom in" (Ctrl++)

    Zoom in image.

    "View->Image->Zoom out" (Ctrl+-)

    Zoom out image.

    "View->Font->Zoom in"

    Zoom in font.

    "View->Font->Zoom out"

    Zoom out font.

    "View->Next question" (Ctrl+Next)

    Go the next question.

    "View->Previous question" (Ctrl+Back)

    Go the previous question.

    "View->Question number..." (Ctrl+G)

    Go on the number of the question.


    Contents


    Menu "Insert"

    "Insert->Image->Insert"

    Inserts an image in the test.

    "Insert->Image->Change"

    Modifies the image in the test for the new.

    "Insert->Image->Delete"

    Removes the image from the test.

    "Insert->Question->Insert" (Ctrl+Shift+A)

    Inserts a new question in the test.

    "Insert->Question->Delete"

    Delete a question from a test.


    Contents


    Menu "Format"

    "Edit->Font..." (Ctrl+F)

    Opens a dialog box to change the font. He changed the entire text.

    "Format->Alignment->Justify left"

    Alignment text to the left.

    "Format->Alignment->Justify on center"

    Alignment text on the center.

    "Format->Alignment->Justify right"

    Alignment text to the right.

    "Format->Alignment->Fill"

    Alignment text to the fill.

    "Format->Register->Uppercase" (Ctrl+Shift+U)

    Changes the selected characters to uppercase.

    "Format->Register->Lowercase" (Ctrl+Shift+L)

    Changes the selected characters to lowercase.


    Contents


    Menu "Table"

    "Table->Insert..." (Ctrl+T)

    Opens a dialog box for selecting parameters of the table, followed by insertion into the text.

    "Table->Add rows"

    Opens a dialog box to select the number of added lines.

    "Table->Add columns"

    Opens a dialog box to select the number of added columns.

    "Table->Resize..." (Ctrl+Shift+R)

    Opens a dialog box to select new parameters table.


    Contents


    Menu "Service"

    "Service->Statistics" (Ctrl+Shift+S)

    Opening the window of the statistics.

    "Service->Mode password" (Ctrl+P)

    Changes the current mode password.

    "Service->Options" (Ctrl+Shift+O)

    Opens the settings window.


    Contents


    Menu "Mode"

    "Mode->Editing" (Ctrl+Shift+E)

    Switching program in mode of editing test.

    "Mode->Testing" (Ctrl+Shift+T)

    Switching program in mode of testing.


    Contents


    Menu "Help"

    "Help->User manual" (F1)

    Opens a program manual.

    "Help->Donate" (Alt+D)

    View donations page.

    "Help->Get source" (Alt+S)

    Get the source code of the program.

    "Help->Get techsupport" (Alt+T)

    Open page the techsupport.

    "Help->Report a bug..." (Alt+B)

    Report a bug, using the bug-tracker.

    "Help->Check for updates" (Alt+U)

    Check for updates on the internet.

    "Help->About program" (F2)

    Displays information about the program and its version.


Lab Free Technologies © 2009 - 2016