Klen-library 1.0.5 
Language
Sections
Search
Electronic stores
Counter
Text guide
 

    User manual: "Klen-library" 1.0.5(01/20/2013)

    Copyright © 2009 - 2013 Lab Free Technologies(IE Flegontov D.M.)


    The program for creating electronic books. Designed for professional writing and reading electronic books and electronic manuals.

    If there is a large market for software, which shows the office suites that contain a text editor, which has much more functionality than the Klen-library, the question arises about the need to use this program in educational institutions. The answer to that comes of itself, after reading the opportunities offered by Klen-library: using a database to store all the information, backup database libraries, access rights to edit the book, adding more information into the database, using the module tests for checking knowledge and etc. The book is in the file format xwb encrypted and in a compressed state, while economically using the free space on the hard disk.

    Klen-library was created using the rules of ergonomics, and therefore learn to work in it will be quite simple. The user is given complete freedom to work with the program. This freedom is the use of any operating system installed on both the computer clients (students), and the server computer. All this became possible due to the fact that the program is cross-platform, uses a database SQLite3 and don't writes in the registry that allows it to quickly port and deploy to any number of computers. At a separate order - will be ported to your platform.Possible options:
    Architectures: Intel x86, amd64(EM64T), PowerPC, PowerPC64, ARM(!)
    Platforms: Windows, MacOSX, GNU / Linux, Solaris, FreeBSD, MeeGo, eComStation(OS/2), NetBSD, QNX, OpenBSD, WinCE, Symbian.

    Assemblies are available now for 4 architectures: Intel x86, amd64(EM64T), PowerPC, ARM(!) and 3 platforms: Windows, MacOSX, GNU / Linux.


    Contents

    Library can operate in two modes: "Editing" and "Reading". In Editing mode, you can create and edit the book. In Reading mode can be, respectively do viewing and reading the book.

    The main window shown on Image 1.


    Image 1. "Main window".

    All of the following actions performed from the program menu, also duplicated in the dashboards. For the convenience of searching, button names correspond to the names of the menu items. It should be noted that for reading books, mostly used standard toolbar buttons, but for editing, is a separate "Edit toolbar" and "Formatting toolbar". There's also a search bar. Users, if necessary, can leave one or the other panel on the screen. Select the display panel produced by right-clicking on the main menu bar or on the free part is an open bar. By default, visible only to the standard panel. This is a quick way to change, which will not save settings panel appears when you exit the program.

    Contents


    When you first open the program checks to see if the options file in the system. If he is not found, it shows the welcome screen(Image 2) with short information about the program.
    Location of the file by default:
    Windows - %APPDATA%;
    Unix - $HOME/.config;
    Embedded Linux - $HOME/Settings;
    Mac OS X - $HOME/.config;


    Image 2. "Welcome".


    Contents


    When you start the program will need to enter a user name. This name will be used for recording your stats reading. Image 3.


    Image 3. "Entering a username".


    Contents


    Create, open, backup and restore libraries, is from the "Library". Archived library with compression. Compression can be up to 5 times.


    Contents


    To create a book should be: in the "Book" click on "Create..." - opens "Creating a new book, as shown on Image 4.


    Image 4. Window Creation of a new book ".

    In this window there are 4 single-line field for text entry: "Book name", "Printing house", "Category", "Subcategory" and one field to enter the number "Year", padded to these values are changed accordingly: The book name, printing house, category, subcategory and year of publication of future books.
    Since the "Year" is a number, an indication of the dates of literary works of antiquity can be a negative value. I mean, III-rd century BC to as -258.


    Contents


    Edit text, created e-book comes from the menu "Edit" and "Format". The following functions: undo, redo, the selection of the text, font, cut, copy, paste text, change alignment and register of the text.


    Contents


    In order to insert the image into the text to select "Insert->Image...". Supported formats: JPG, JPEG, GIF, BMP, TIFF, PNG, XPM, XBM, PPM.


    Contents


    Add / Remove page comes from the menu "Insert->Page->Insert" / "Insert->Page->Delete", respectively.


    Contents


    Opening the book comes from the menu "Book", selecting "Open..." - Open dialog list of books ", which is shown on Image 5.


    Image 5. Window "List of books".

    When you select a row with the name of that book and subsequent clicking "OK", is opening a window "Enter password", if the book was protected by a password. After entering the password - open book. Should also be noted that the password is the book I ask only in edit mode. When viewing a book is easy to open for reading without asking for password. This was done because the "Klen-library" originally was designed for schools so that students can only read the material of electronic aids are not there making their own adjustments. Simply put - that is not spoiled. Password is given to each book creator (teacher).


    Contents


    "Book->Import->Folder..." making a batch import all the files in the selected folder. Import one book can be from the "Book->Import->One book...". Available import of 3 formats: XWB (your own portable format), TXT (plain text format to utf-8), and HTML. Import HTML-format, is made in such a way that is best understood as html-file exported by the program OpenOffice Writer. This will facilitate the conversion of books from the documents in *.doc (MS Word) and other formats.

    Menu "Book->Export..." allows you to export the book in the following formats: XWB, PDF, PostScript, HTML, RTF, TXT. When exporting to xwb - the book is encrypted and compressed at about 5(!) times. Support for RTF-format is partial, therefore please wait the next version :)

    When selecting the "Book->Export->All the books..." opens a window to export all the books. After selecting the file type - the program saves all the books from the database in the proper format. Image 6.

    Image 6. Select the type of file to export the book.


    Contents


    Library is a database SQLite 3. Therefore, the addition or removal of books is by adding or removing corresponding entries in the database. This suggests that the database file can be placed on a file server. With this organization, storage base, provides simultaneous operation of multiple workstations, both in view and in edit mode. It will be necessary to take into account that when you add / delete records preservation is automatically but when you change records, padded with the names in her book, keep a record will need to manually, by pressing the button "Save." When close window changed record (write name) automatically will not be saved.


    Contents


    Paging pages caused by one of the menu "View" - items "Next Page", "Previous Page". You can also enter is appropriate page number in the "Enter the required page", accessible from the menu "View->Input page number..."


    Contents


    Changing the language is in the window "Options".


    Contents


    Password books changes from the item "Service->Book password".


    Contents


    Will set a password the first switching in the edit mode, but changing from the item "Service->Mode password".


    Contents


    Saving is selecting the menu item "Book->Save".


    Contents


    In the "Options" there is a choice of password protection of the book (Sha1-hash), setting up the show toolbars, the ability to remember the last open database library, the choice of interface language. As there is a paths to the library, to the file of statistics, to the file options of program(Image 7).

    Image 7. "Window Options".


    Contents


    "Book->Print" allows to print books with full text formatting.


    Contents


    Program has the ability to store arbitrary additional information in the form of links to individual files. This is especially useful if to any art book has a film based on it - joins as a link to a video film. To abstracts of any composer would be to add links to audio files of his musical works. Important documents associated link to the files of other documents, similar subjects, but unsupported Electronic library formats (MS Office, OpenOffice). You can create a gallery of images, attaching links to pictures, etc. There is a split into categories. All five of them: Music, Films, Photos, Documents, Programs. All added files attached so far only to the entire database, not to individual books. Therefore, the book can provide a link to the existing external file in the library. (Image 8)


    Image 8. Window "List of files".


    Contents


    To insert a table, select the menu item "Table->Insert...", opens the parameters of the table: the number of rows and number of columns. After selecting the required number - will create a table and insert into the text books.


    Contents


    There is a function of working hours, held for the creation or reading a book. This is especially useful when you need to know who the students or pupils poorly refers to the process of learning and reading e-books in class, in particular. Also, the teacher can reduce the time if he has a lot of e-books created spent, for example, to find the books he edited, and those still standing to edit. Looking at the statistics of this will be found in seconds.(Image 9)


    Image 9. Window "Statistics".


    Contents


    Exit out of the program from the menu "Book->Quit".


    Contents


    0.1.3: For those who already have a database of books and software at least version 0.1.x (up to 0.1.3), you must export all the books in the files .xwb. Then, the new version to import into a new database, because book format has changed little and the old database is not supported.
    0.1.9: Due to the fact that the changed format of the book xwb, need to be in the old version (0.1.3, 0.1.4, 0.1.8) to import into a database all the books. Open the database in the new version and export all the books in the file xwb, the new format.
    1.0.0: Changed the database format and the book xwb. In version 0.1.9, 0.2.5 need to import all the books into the database. Open the library in the new version. Then export into the book xwb of new format. Then create a new database of a library and import the all the books into the library. Moreover, the number and sequence of images can lose, for which I apologize. :) In the next version of support for older (0.1.9, 0.2.5) databases will be deleted, because they contained errors. It is recommended to upgrade to the current version.
    1.0.5: The format database library version 1.0.0. Removed support for the old (0.1.9, 0.2.5) database library.


    Contents


    Available system for testing of Shelk-test, which allows not closing the book, test. "Service->Test"- opens the program "The Shelk-test". This program is an external (a separate product of laboratory). It is a third module (Creation, Testing, Journal of report). Full job description read the user manual for this program.
    It is worth noting that if the options of the Klen-library path to a different testing system, it can also be started from the "Tools->Test". This universalizes program and allows you to use the system which will be able to solve the tasks in its entirety, without imposing the use of laboratory products only. Thus preserved the freedom of choice.


    Contents


    Main Menu

    Menu "Library"

    "Library->Create..." (Ctrl+Shift+N)

    Creates a new library

    "Library->Open..." (Ctrl+Shift+O)

    Opening library.

    "Library->Restore..."

    Restore library from the archive

    "Library->Close"

    Close of library.

    "Library->Backup..." (Ctrl+Shift+B)

    Backup of library

    "Library->Exit" (Ctrl+Q)

    Produces closure program


    Contents


    Menu "Book"

    "Book->New..." (Ctrl+N)

    Opens a window in which you can enter the parameters of the new book

    "Book->Open..." (Ctrl+O)

    Open book from the database

    "Book->Import->Folder..."

    Opens a dialog box for the import all of textbooks from the selected folder

    "Book->Import->One book..." (Ctrl+I)

    Opens a dialog box for the import of one selected textbook

    "Book->Close"

    Close opened book

    "Book->Save..." (Ctrl+S)

    Save opened book to database

    "Book->Export->All books)..."

    Opens a dialog box for the export all of textbooks.

    "Book->Export->This book..." (Ctrl+E)

    Opens a dialog box for the export of this textbook

    "Book->Print..." (Ctrl+P)

    Opens a dialog box to print books.


    Contents


    Menu "Edit"

    "Edit->Undo" (Ctrl+Z)

    Cancels produced action

    "Edit->Redo" (Ctrl+Shift+Z)

    Repeats undone action

    "Edit->Select All" (Ctrl+A)

    Selects all the text on the current page

    "Edit->Cut" (Ctrl+X)

    Cuts the selected text to the clipboard

    "Edit->Copy" (Ctrl+C)

    Copies the selected text to the clipboard

    "Edit->Paste" (Ctrl+V)

    Pastes text from the clipboard


    Contents


    Menu "View"

    "View->Find text" (Ctrl+F)

    Looks for your text

    "View->Next page" (Ctrl+Вправо)

    Go to the next page of book...

    "View->Previous page" (Ctrl+Влево)

    Go to the previous page of book

    "View->Input number page..." (Ctrl+Alt+N)

    Makes paging on page number you have entered


    Contents


    Menu "Insert"

    "Insert->Page->Insert" (Ctrl+Shift+A)

    Insert of page in the book

    "Insert->Page->Delete" (Ctrl+D)

    Delete page from the book

    "Insert->Image..." (Ctrl+Alt+I)

    Inserting image to book


    Contents


    Menu "Format"

    "Edit->Font..." (Ctrl+Shift+F)

    Opens a dialog box to change the font. He changed the entire text

    "Format->Alignment->Justify left"

    Alignment text to the left

    "Format->Alignment->Justify on center"

    Alignment text on the center

    "Format->Alignment->Justify right"

    Alignment text to the right

    "Format->Alignment->Fill"

    Alignment text to the fill

    "Format->Register->Uppercase" (Ctrl+Shift+U)

    Changes the selected characters to uppercase

    "Format->Register->Lowercase" (Ctrl+Shift+L)

    Changes the selected characters to lowercase


    Contents


    Menu "Table"

    "Table->Insert..." (Ctrl+Shift+T)

    Opens a dialog box for selecting parameters of the table, followed by insertion into the text.

    "Table->Add rows" (Ctrl+Shift+R)

    Opens a dialog box to select the number of added lines

    "Table->Add columns" (Ctrl+Shift+C)

    Opens a dialog box to select the number of added columns

    "Table->Resize..." (Ctrl+R)

    Opens a dialog box to select new parameters table


    Contents


    Menu "Service"

    "Service->Statistics" (Ctrl+Shift+S)

    Opening the window of the statistics

    "Service->Additionally"

    Opens a dialog box to select the type of display more information

    "Service->Book password" (Ctrl+Shift+P)

    Change the current password of the book

    "Service->Regime password" (Ctrl+Alt+P)

    Changes the current mode password

    "Service->Test" (Ctrl+T)

    Open external program "Shelk-test"

    "Service->Options..." (Ctrl+Alt+O)

    Opens the settings window


    Contents


    Menu "Regime"

    "Regime->Editing" (Ctrl+Shift+E)

    Switching program in edit mode of the book

    "Regime->Viewing" (Ctrl+Shift+V)

    Switching program mode of reading the book


    Contents


    Menu "Help"

    "Help->User's Guide" (F1)

    Opens this User Manual

    "Help->Donate" (Alt+D)

    View donations page

    "Help->Get Source" (Alt+S)

    Get the source code of the program

    "Help->Get techsupport" (Alt+T)

    Open page the techsupport

    "Help->Report a bug..." (Alt+B)

    Report a bug, using the bug-tracker.

    "Help->Check for updates" (Alt+U)

    Check for updates from the internet.

    "Help->About" (F2)

    Displays information about the program and its version


Lab Free Technologies © 2009 - 2016